“Keep me logged in”

Talk with the MIMForum staff! This is the section for discussing the workings of this forum. Your suggestions always welcome!
User avatar
Karl Wicklund
Posts: 151
Joined: Sun Jan 08, 2012 12:42 am
Location: NW Wisconsin
Contact:

“Keep me logged in”

Post by Karl Wicklund »

Is anyone else having trouble staying logged in? I haven’t timed it, but if I’m gone for a few minutes I’m still logged in. If it’s the next day, the system asks for username and password again. This is costing me several dozen keystrokes a week, so you can imagine the crisis!

Seriously, thanks for the care that goes into keeping this place up and running!
Kaptain Karl

User avatar
Charlie Schultz
Site Admin
Posts: 1345
Joined: Fri Dec 23, 2011 6:53 pm
Location: Atlanta, GA

Re: “Keep me logged in”

Post by Charlie Schultz »

We made some changes to the cookie settings and session length settings on Saturday to try to fix this (and be sure to check the "remember me" box when you log in. Let me know if you still see the problem.

User avatar
Bob Gramann
Posts: 975
Joined: Fri Jan 06, 2012 11:08 am
Location: Fredericksburg, VA
Contact:

Re: “Keep me logged in”

Post by Bob Gramann »

Things seem to have been fixed for me.

User avatar
Karl Wicklund
Posts: 151
Joined: Sun Jan 08, 2012 12:42 am
Location: NW Wisconsin
Contact:

Re: “Keep me logged in”

Post by Karl Wicklund »

Works here, too! Thanks again.
Kaptain Karl

User avatar
Karl Wicklund
Posts: 151
Joined: Sun Jan 08, 2012 12:42 am
Location: NW Wisconsin
Contact:

Re: “Keep me logged in”

Post by Karl Wicklund »

I’ve been having this trouble again. If I refresh, it m logged out.
Kaptain Karl

User avatar
Barry Daniels
Posts: 2676
Joined: Thu Jan 05, 2012 10:58 am
Location: The Woodlands, Texas

Re: “Keep me logged in”

Post by Barry Daniels »

I had the same problem but I made one change in my browser which fixed it. Let me see if I can retrace my steps.
MIMF Staff

User avatar
Barry Daniels
Posts: 2676
Joined: Thu Jan 05, 2012 10:58 am
Location: The Woodlands, Texas

Re: “Keep me logged in”

Post by Barry Daniels »

I am using Safari on a Mac Powerbook. I went to Preferences/Privacy/ and I checked the box next to "Website Tracking" which says "Prevent cross-site tracking". I don't know what that means but I now stay logged into the MIMF.
MIMF Staff

User avatar
Karl Wicklund
Posts: 151
Joined: Sun Jan 08, 2012 12:42 am
Location: NW Wisconsin
Contact:

Re: “Keep me logged in”

Post by Karl Wicklund »

That did it! How did you figure that out, Barry?
Kaptain Karl

User avatar
Barry Daniels
Posts: 2676
Joined: Thu Jan 05, 2012 10:58 am
Location: The Woodlands, Texas

Re: “Keep me logged in”

Post by Barry Daniels »

I was just flipping different switches trying to see if anything worked. Glad it worked for you too. Are you on a Mac too?
MIMF Staff

User avatar
Karl Wicklund
Posts: 151
Joined: Sun Jan 08, 2012 12:42 am
Location: NW Wisconsin
Contact:

Re: “Keep me logged in”

Post by Karl Wicklund »

I am on a Mac, yeah. iPhone and MacBook.
I was having the trouble with a windows machine I'm on at times. That seems to have cleared up soon after the update, though.
Kaptain Karl

User avatar
Bob Gramann
Posts: 975
Joined: Fri Jan 06, 2012 11:08 am
Location: Fredericksburg, VA
Contact:

Re: “Keep me logged in”

Post by Bob Gramann »

Safari on a iPad is not keeping me logged in for more than about an hour. Firefox on the same iPad works a bit longer, but to view unread posts on the forum a few times a day requires that I log in each time. The upgrade did not fix that.

User avatar
Charlie Schultz
Site Admin
Posts: 1345
Joined: Fri Dec 23, 2011 6:53 pm
Location: Atlanta, GA

Re: “Keep me logged in”

Post by Charlie Schultz »

Bob, any chance you have "private browsing" turned on in those browsers? I think that interferes with the cookie settings (e.g., "keep me logged in").

User avatar
Bob Gramann
Posts: 975
Joined: Fri Jan 06, 2012 11:08 am
Location: Fredericksburg, VA
Contact:

Re: “Keep me logged in”

Post by Bob Gramann »

I have “prevent cross-site” tracking set. On Barry’s suggestion, I tried turning it off, but it didn’t make any difference. I can’t find a switch for private browsing.

User avatar
Charlie Schultz
Site Admin
Posts: 1345
Joined: Fri Dec 23, 2011 6:53 pm
Location: Atlanta, GA

Re: “Keep me logged in”

Post by Charlie Schultz »

I don't use safari, but I found this:
Turn off Private Browsing (iOS Safari) On an iPhone, iPad, or iPod touch, open Safari, then tap (bottom right corner). Tap Private (lower left corner) to turn private browsing off. While Private Browsing is on, Safari appears black or dark instead of white or gray.

User avatar
Bob Gramann
Posts: 975
Joined: Fri Jan 06, 2012 11:08 am
Location: Fredericksburg, VA
Contact:

Re: “Keep me logged in”

Post by Bob Gramann »

That was for a different version of ios, but a google search found the switch for me. It wasn’t and hasn’t been on. My browser has never been in private mode (some of the fields went dark when I switched it on—I’ve never seen that before).

User avatar
Barry Daniels
Posts: 2676
Joined: Thu Jan 05, 2012 10:58 am
Location: The Woodlands, Texas

Re: “Keep me logged in”

Post by Barry Daniels »

Safari's private browsing is turned on by going up to the top menu, pull down the File stack, then select New Private Window. Only that window will be in Private mode.
MIMF Staff

User avatar
Charlie Schultz
Site Admin
Posts: 1345
Joined: Fri Dec 23, 2011 6:53 pm
Location: Atlanta, GA

Re: “Keep me logged in”

Post by Charlie Schultz »

I'm pretty sure the "keep me logged in" setting is in the cookies, so maybe delete the MIMF cookies and try? The cookies did change once or twice during the recent upgrade.

Also it seems there is (or used to be) a setting in Safari to logout after X minutes. Likewise, a setting to block cookies.

User avatar
Bob Gramann
Posts: 975
Joined: Fri Jan 06, 2012 11:08 am
Location: Fredericksburg, VA
Contact:

Re: “Keep me logged in”

Post by Bob Gramann »

That worked with the initial upgrade, then with the last, the new keep me logged in problems started. I tried deleting the cookies again after the new upgrade and it didn’t help. This afternoon, I deleted the cookies again. I’ve now been logged in with Safari for several hours. Thank you.

However, after deleting the cookies in Firefox for the iPad, the log in ages out in less than an hour. Odd problem.

User avatar
Charlie Schultz
Site Admin
Posts: 1345
Joined: Fri Dec 23, 2011 6:53 pm
Location: Atlanta, GA

Re: “Keep me logged in”

Post by Charlie Schultz »

Probably not the issue here, but I've noticed that some of my old bookmarks and shortcuts were http://www.mimf...

So if I was logged in via https://www.mimf... and then clicked an old shortcut or bookmark (that was still http:), it would show me as not logged in.

User avatar
Bob Gramann
Posts: 975
Joined: Fri Jan 06, 2012 11:08 am
Location: Fredericksburg, VA
Contact:

Re: “Keep me logged in”

Post by Bob Gramann »

Not the issue here, but I hadn’t noticed the switch to https. All of my connections up to this minute were to http. Thank you for making that change.

Post Reply